AM1808-armv5 support

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

AM1808-armv5 support

praveen pujari
Hello,

Does valgrind support ARM1808-armv5. When I cross compile I get an error saying not supported.
The website says ARM/LINX upto and including ARMv7.

Is it really supported or am I making a mistake while cross-compiling.

Thanks in advance,
Praveen

------------------------------------------------------------------------------

_______________________________________________
Valgrind-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/valgrind-users
Reply | Threaded
Open this post in threaded view
|

Re: AM1808-armv5 support

John Reiser
> Does valgrind support ARM1808-armv5. When I cross compile I get an error saying not supported.
> The website says ARM/LINX upto and including ARMv7.
>
> Is it really supported or am I making a mistake while cross-compiling.

The armv5 and armv6 architectures are not supported.  (grep "armv[56]" /proc/cpuinfo)
The hardware is deficient because it does not provide reasonable support for threads.
If you are highly motivated then the bug tracker contains patches which enabled
support a couple years ago for armv5 for single-threaded memcheck only.

armv7 is the minimum supported hardware.  A RaspberryPi works very well,
especially B+ version 2 with 1GiB RAM.


------------------------------------------------------------------------------
_______________________________________________
Valgrind-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/valgrind-users