Quantcast

Val grind on OS X 10.11.2

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Val grind on OS X 10.11.2

Castellana Michele
Dear all,
I am having troubles building Valgrind on OS X 10.11.2 El capitan. I am aware that valgrind does not fully support this OS, but I was wondering if any of you found a way to fix this specific problem. After downloading valgrind-3.12.0.tar.bz2 from http://valgrind.org/downloads/current.html and unzipping the file in a folder, I successfully ran './autogen.sh' and './configure'. However, when I run ‘make' I get the usual error 

m_syscall.c:708:1: error: unknown type name ‘__private_extern__’

which I fixed by adding '#define __private_extern__ extern’ to 'coregrind/m_syscall.c’, 'coregrind/m_syswrap/syswrap-darwin.c’ and to 'coregrind/vg_preloaded.c’ as indicated in http://superuser.com/questions/630674/valgrind-installation-errors-on-osx-10-8 . 

When I run make again, I get the error 

Undefined symbols for architecture i386:
  "___ctzdi2", referenced from:
      _doRegisterAllocation in libvex-x86-darwin.a(libvex_x86_darwin_a-host_generic_reg_alloc2.o)
ld: symbol(s) not found for architecture i386
make[3]: *** [memcheck-x86-darwin] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Do you know how to fix this?

Thank you. 
Best,
Michele



------------------------------------------------------------------------------
The Command Line: Reinvented for Modern Developers
Did the resurgence of CLI tooling catch you by surprise?
Reconnect with the command line and become more productive.
Learn the new .NET and ASP.NET CLI. Get your free copy!
http://sdm.link/telerik
_______________________________________________
Valgrind-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/valgrind-users
Loading...